PDA

View Full Version : 2001 Miata won't start after driving: Diagnosis help



Demon I Am
09-16-2016, 05:11 PM
So my friend has an '01 with the big FFS kit installed. Eaton MP62, 5,6 injector, fuel rail, walboro 190? pump. Since the install, he's always had some issues, high idle, running rough, etc. Such is the way of modification. We've slowly ironed out a lot of the wrinkles but this last one has been giving me hell.

When the car is cold, it'll start up just fine, the idle's still a little higher than it should be, but not terrible. After driving normally for 10-15 minutes, and turning the car off. you can not get it to fire up. It will turn over, but not crank. It does not cut off while driving.

Main relay, fuel pump relay, cam sensor, and crank sensor are all brand new. What is the next thing to check? It has to be spark or fuel related correct?

Guess I could check the coil pack/ pull the plugs and look for spark on all cylinders. Anything else that could heat soak and kill the car?

Demon I Am
09-19-2016, 12:17 PM
Bump?

kung fu jesus
09-19-2016, 12:36 PM
Guess I could check the coil pack/ pull the plugs and look for spark on all cylinders. Anything else that could heat soak and kill the car?


Answered your own question. Can't really add much without more info. What DOESN'T it have when this happens? Fuel, spark, or air?

Greasemonkey2000
09-19-2016, 03:07 PM
The "brushes" in the starter? When they are going out it will make warm/hot starts difficult. Had similar issue but now it happens even on cold starts. :fp:

Slampen
09-19-2016, 03:16 PM
if it is related to the FFS kit I know that Tom@FFS gives the best support.

John J
09-19-2016, 06:31 PM
Could it be a faulty relay that does not function when hot?

HarryB
09-20-2016, 01:58 PM
Tony, I am confused by this:


It will turn over, but not crank.

Does the starter motor crank the engine or not?

Demon I Am
09-20-2016, 02:33 PM
Engine turns over "rarrarararaarar"
will not crank (fire) "Vroom"

HarryB
09-20-2016, 02:48 PM
Hahaha, that was a hell of an explanation! I was thinking of issues with starter motor and/or solenoid heatsoak, but I am wrong.

NCGreasemonkey
09-20-2016, 08:35 PM
If you have all the replaced parts put the OEs back on and restart your diag.. With some aftermarket parts you might be introducing your own problem.

Go back to scratch and see if there is no spark ( use an adjustable kV tester and wind it out to 25-30). Needs to be a blue-white arc. Not red. Is the fuel aerated (read in to this boiled) in the fuel rail. Bubbles in the release line. Are the injectors pulsing (getting the signal). Noid light. All can be checked with low cost tools from Harbor Freight.

If you see nothing or something on one of the cheap tools check a known good running car and see if it passed the test. If not bad tool. If so. closing in.

Two or four-channel scopes are my go to with problem childs. But one real quick question. What does the security light do when it will not crank?

mx54life
09-21-2016, 04:57 AM
if it is related to the FFS kit I know that Tom@FFS gives the best support.

I second that.

He is almost always available when it comes to FFS.

BTW is the car actually overheating?