Results 1 to 12 of 12

Thread: bogging out and shutting off :(

LIKE THIS THREAD!

  1. #1
    Idling - Listen to it purr... Gary's Avatar
    Join Date
    Jan 2012
    Posts
    24
    Thanks Given
    0
    Thanked 0 Times in 0 Posts

    Angry bogging out and shutting off :(

    What's up guys, Im finally back now that I have my car from it being away for 2 years from being built. Hopefully I can make this clear enough without getting myself upset that my NA likes to bog and shutoff whenever it feels like it.

    I have a 90 NA w/99 swap and S/C.

    Ended up sending my car to a Miata shop to to get my whole motor built, forged internals, supercharger kit,MS2, trans, diff the whole enchilada. The car ran perfectly fine as it should for about 3 weeks (300 miles) and after that it started being bipolar, it began to shut off during idle when warming up, while driving especially when making left turns and when trying to turn it back on it'll backfire and just crank but won't turn over, bogging out while my wideband read low as 10.1 and high as 17.2. These are the issues that I've been dealing with, so I send the car back and was told the CAS took a shit and was replaced, 2 weeks later(50 miles) I'm back to the same issues. My mechanic said it can be 2 things defective fuel pump(Deatschwerks 255) or fuel pump harness female connector that the gaps might be too stretch out which is a common thing for 1.6 models so he says and also since I'm using the skunk2 throttle body its the reason it shuts off since has no idle control valve but other miata's with the same throttle body don't have that issue. Can that really be the problems I'm dealing with here? What are your suggestions/thoughts ??

    btw Im running a MS2 and 91 pump

  2. #2
    Supporting Member MiataQuest's Avatar
    Drives
    White 1992 turbo Miata LS
    Location
    Detroit, Michigan
    Join Date
    Mar 2016
    Posts
    1,081
    Thanks Given
    849
    Thanked 441 Times in 169 Posts
    Just to eliminate a possible source of the problem, add another ground strap from the engine to the frame of the car. Also add a secondary ground to your MS2 and check your fuel pump ground. Make sure your battery cables are tight and the ground to the frame is clean.

    It is cheap and easy to do.
    The EUNOS MANTICORE SPECIAL EDITION build thread http://mazdaroadster.net/showthread....-EDITION-build

  3. #3
    5,000 rpm - there be torque here! HarryB's Avatar
    Drives
    '04 Strato Blue NB2
    Location
    Greece
    Join Date
    Jun 2015
    Posts
    3,856
    Thanks Given
    2,755
    Thanked 932 Times in 541 Posts
    Added to that, I was under the impression that the Skunk2 TB had a provision for the stock Miata IAC

  4. #4
    Idling - Listen to it purr... Gary's Avatar
    Join Date
    Jan 2012
    Posts
    24
    Thanks Given
    0
    Thanked 0 Times in 0 Posts
    Going to give that a try today and we'll report back if any differences
    Quote Originally Posted by MiataQuest View Post
    Just to eliminate a possible source of the problem, add another ground strap from the engine to the frame of the car. Also add a secondary ground to your MS2 and check your fuel pump ground. Make sure your battery cables are tight and the ground to the frame is clean.

    It is cheap and easy to do.

  5. #5
    Idling - Listen to it purr... Gary's Avatar
    Join Date
    Jan 2012
    Posts
    24
    Thanks Given
    0
    Thanked 0 Times in 0 Posts
    same here, if not might have to try a different shop
    Quote Originally Posted by HarryB View Post
    Added to that, I was under the impression that the Skunk2 TB had a provision for the stock Miata IAC

  6. #6
    Ninja Messiah kung fu jesus's Avatar
    Drives
    1992 Mariner
    Location
    Roswell, GA
    Join Date
    Dec 2011
    Posts
    8,377
    Thanks Given
    1,354
    Thanked 3,736 Times in 1,903 Posts
    A good shop will diagnose before just throwing parts at it.

    It sounds electrical. I might datalog the MS, check the IAT sensor, reset and recalibrate the WBo@, assuming you are running one.

  7. #7
    Idling - Listen to it purr... Gary's Avatar
    Join Date
    Jan 2012
    Posts
    24
    Thanks Given
    0
    Thanked 0 Times in 0 Posts
    Did what others stated above and as well check the IAT and was fine as well reset the wideband and still the same thing.

    Might have to talk with this other shop Tri Point Eng and go from there.

    Quote Originally Posted by kung fu jesus View Post
    A good shop will diagnose before just throwing parts at it.

    It sounds electrical. I might datalog the MS, check the IAT sensor, reset and recalibrate the WBo@, assuming you are running one.

  8. #8
    Idling - Listen to it purr... Gary's Avatar
    Join Date
    Jan 2012
    Posts
    24
    Thanks Given
    0
    Thanked 0 Times in 0 Posts
    Forgot to add that when I did a burnout 10 seconds later the motor hesitated as if it was choking and suddenly the car shuts down and it won't start literally 2-3 mins later without a problem if I leave it alone without cranking it over if not it'll just back fire and struggle trying to turn over.

  9. #9
    Ninja Messiah kung fu jesus's Avatar
    Drives
    1992 Mariner
    Location
    Roswell, GA
    Join Date
    Dec 2011
    Posts
    8,377
    Thanks Given
    1,354
    Thanked 3,736 Times in 1,903 Posts
    Lol! Good luck.

  10. #10
    The Technical Guy RuckkehrMiata's Avatar
    Drives
    Red `89 NA
    Location
    Los Angeles, CA
    Join Date
    Jan 2012
    Posts
    861
    Thanks Given
    231
    Thanked 381 Times in 196 Posts
    Definitely datalog, it sounds like the MS itself might even be having problems. Some of your symptoms closely resemble when mine was having issues (especially the backfire but not starting)
    `89 NA build: 二回目 My (defunct) `92 NA build: Ruckkehr

  11. #11
    Ninja Messiah kung fu jesus's Avatar
    Drives
    1992 Mariner
    Location
    Roswell, GA
    Join Date
    Dec 2011
    Posts
    8,377
    Thanks Given
    1,354
    Thanked 3,736 Times in 1,903 Posts
    ^ that.

    I had similar issues when the IAT started to flake and when my WBO2 started to foul.

    You're kinda screwed if you can't do a lot of that yourself, you're going to need shops with experience in those aftermarket systems in that car.

  12. #12
    The Technical Guy RuckkehrMiata's Avatar
    Drives
    Red `89 NA
    Location
    Los Angeles, CA
    Join Date
    Jan 2012
    Posts
    861
    Thanks Given
    231
    Thanked 381 Times in 196 Posts
    The shutting off is concerning to me.

    When the car shuts off, does everything power off or does the engine just stop. If it shuts off and the tac is slamming to 0 and everything just dies (not just engine stopping) this is baaad.
    See if you can get it to shut off on its own while plugged in with TunerStudio etc and see if the MS disconnects.

    If this specifically is happening you might be buying a new MS

    Another thing that comes to mind is CAS
    `89 NA build: 二回目 My (defunct) `92 NA build: Ruckkehr

  13. The Following User Says Thank You to RuckkehrMiata For This Useful Post:

    kung fu jesus (06-20-2017)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •