Results 1 to 8 of 8

Thread: 01 Miata LS Engine problem

LIKE THIS THREAD!

  1. #1
    Idling - Listen to it purr...
    Drives
    2001 Miata LS
    Location
    Louisiana
    Join Date
    Oct 2017
    Posts
    6
    Thanks Given
    3
    Thanked 2 Times in 1 Post

    01 Miata LS Engine problem

    Hello, I am having an issue with my 2001 Miata LS I was hoping someone might be able to help me on. The car runs fine, but after driving a few miles and the engine getting to normal temp, it will die at idle whether in park or drive. Many times after pulling under the carport with the car in park it will just die. It does not give a code, and it does not miss like it is running out of gas, just quits but will start back up. I have changed the timing belt a few months back, new cam shaft sensor, new crankshaft sensor, and new fuel filter. It also has new plugs, plug wires, and coil packs. I have also replaced the O2 sensors. I would appreciate any advice if anyone has experienced this problem. Thanks for any help.

  2. #2
    Ninja Messiah kung fu jesus's Avatar
    Drives
    1999 White
    Location
    Roswell, GA
    Join Date
    Dec 2011
    Posts
    13,565
    Thanks Given
    1,956
    Thanked 5,318 Times in 2,545 Posts
    Dirty throttle body, throttlebody idle adjustment, or dirty/failing idle control valve (ICV).

  3. #3
    Ninja Messiah kung fu jesus's Avatar
    Drives
    1999 White
    Location
    Roswell, GA
    Join Date
    Dec 2011
    Posts
    13,565
    Thanks Given
    1,956
    Thanked 5,318 Times in 2,545 Posts
    It may also a simple, minor vacuum leak that shows itself after the car is past cold start.

  4. The Following User Says Thank You to kung fu jesus For This Useful Post:

    Pedalman (01-29-2018)

  5. #4
    Idling - Listen to it purr...
    Drives
    2001 Miata LS
    Location
    Louisiana
    Join Date
    Oct 2017
    Posts
    6
    Thanks Given
    3
    Thanked 2 Times in 1 Post
    Thanks, I appreciate it. I will try to clean it and look around for a vacuum leak, it is random and hard to find. Thanks again.

  6. #5
    6,000 rpm - mere mortals would shift Demon I Am's Avatar
    Drives
    2004 NB2-2015 428i-2018 WRX-1976 C10
    Location
    Raleigh, NC
    Join Date
    Jan 2012
    Posts
    6,910
    Thanks Given
    1,980
    Thanked 1,219 Times in 755 Posts
    starter fluid is your friend for finding vac leaks

  7. The Following 2 Users Say Thank You to Demon I Am For This Useful Post:

    Jarrett (01-26-2018),Pedalman (01-29-2018)

  8. #6
    Idling - Listen to it purr...
    Drives
    2001 Miata LS
    Location
    Louisiana
    Join Date
    Oct 2017
    Posts
    6
    Thanks Given
    3
    Thanked 2 Times in 1 Post
    After this intermittent proble of the engine stalling I finally found the issue. The wire coming from the crankshaft position sensor running upwards to the plug was rubbing against the pulley. It had already cut the insulation on the wire and it appears that it was grounding out against the pulley. I run a scan with my BlueDriver and came back with P0343, prior to yesterday, the check engine light never came on. We taped the bad spot in the wire and tie strapped it away from the pulley and it cranked right up. Seems to be running fine now. I wanted to share what I found. Bad design on that wire placement. Thanks to all who posted to help, I appreciate it.

  9. The Following 2 Users Say Thank You to Pedalman For This Useful Post:

    Agent☣Orange (02-11-2018),kung fu jesus (02-11-2018)

  10. #7
    Ninja Messiah kung fu jesus's Avatar
    Drives
    1999 White
    Location
    Roswell, GA
    Join Date
    Dec 2011
    Posts
    13,565
    Thanks Given
    1,956
    Thanked 5,318 Times in 2,545 Posts
    Awesome! Glad it was an easy fix! Thanks for reporting back!

  11. #8
    Deep-state actor ☚ ☻ ☛ Agent☣Orange's Avatar
    Drives
    🚕
    Location
    🍊SWFL🏝
    Join Date
    Apr 2010
    Posts
    18,364
    Thanks Given
    3,084
    Thanked 3,069 Times in 1,796 Posts
    I have an LS but no wisdom with Miata swaps however, my dad’s Miata suffered exactly the same thing during a water pump change. His PS pulley cut into the wiring harness and disabled the motor at the end of the driveway. Better there than a hundred miles away.


    "No bueno..." Mrs. Phatmiata

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •