Page 50 of 53 FirstFirst ... 404344454647484950515253 LastLast
Results 736 to 750 of 791

Thread: This ain't no build thread!

LIKE THIS THREAD!

  1. #736
    4,000 rpm - entering the fun zone HarryB's Avatar
    Drives
    '04 Strato Blue NB2
    Location
    Greece
    Join Date
    Jun 2015
    Posts
    1,940
    Thanks Given
    3,733
    Thanked 1,301 Times in 765 Posts
    Shit

  2. #737
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    Quote Originally Posted by Agent☣Orange View Post
    Here’s some light reading while you’re down:

    Burning Iranian tanker carrying 150,000 tons of oil is at risk of EXPLODING after colliding with a freighter near Shanghai
    Fierce fire and huge plumes of black smoke are coming out of oil tanker Sanchi
    The Panama-registered ship collided with a freighter on Saturday evening
    Authorities have struggled to find 32 crew members and contain oil spewing


    Read more: http://www.dailymail.co.uk/news/arti...#ixzz53bwfFokM
    I saw that, here is my go-to site for maritime news: www.gcaptain.com. It's amazing what you see on there sometimes.

    A fire at sea is no laughing matter. Considering you have to fight it yourself with the tools and individuals at hand, it can get dicey.
    '00 SE, intercooled BRP MP62, Reverant MS2, Ohlins DFV, Konig Flatout (now X 2)
    __________________________________________________ ____________
    This ain't no build thread!

  3. #738
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    I've been ailing so haven't gotten anything done lately. Now that I am finally recovering, I took the plunge and bought a Momo Fighter steering wheel along with a MS hub to mount it on. Hoping by the time it shows up I will be fully fit and can get on with work.

  4. The Following 2 Users Say Thank You to chiefmg For This Useful Post:

    HarryB (01-15-2018),tsingson (01-15-2018)

  5. #739
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    Steering wheel and hub showed up today:



    The wood is slightly lighter than the stock parts, but I don't think it will be too bad since the wheel is a distance away from the shift knob and e-brake handle. My resistors showed up too, so once it warms some more I will be able to get this installed.

    I thought I had bought a new horn trim ring from eBay, but the seller wrote me the following day to say their inventory was wrong and they had none left. They also checked with Momo but it is NLA. I'll have to find another source if I want one.

  6. The Following 3 Users Say Thank You to chiefmg For This Useful Post:

    Greasemonkey2000 (02-02-2018),MiataQuest (01-18-2018),tsingson (01-23-2018)

  7. #740
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    Spent a little more money. Bought a trim ring off eBay for the wheel, a horn button from revlimiter and some screws for the wheel as is (got these from Ace Hardware). For Internet info, the screw size is M5 X 0.8 X 12mm. Note this is what fits the Mazdaspeed hub I have. I do not have the horn ring yet but it shouldn't be too thick so the 12mm length should do the trick. I will have to buy some different screws for the trim ring once it is in hand, I'll post their length once I have all the pieces in hand.

  8. The Following 2 Users Say Thank You to chiefmg For This Useful Post:

    HarryB (01-19-2018),tsingson (01-23-2018)

  9. #741
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    Yesterday I removed the stock steering wheel and tried mocking up the MS hub. It's going to take some modification to get it to clear the clockspring, and to have the Momo wheel mount up in the correct orientation. No free lunch in this case.

    Warmer today and I'm feeling better so it was out to the garage. Had some work to do on other vehicles first, then it was on to Minnie. Pulled the charge pipes, drained coolant and pulled the radiator. With all the other work I did that was all my back could take for today (pulled muscles from coughing for two weeks). Since I have my other chores done now I can hit it hard tomorrow.

  10. #742
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    I decided to take yesterday off and give my back a chance to recuperate some more. I did receive my revlimiter horn button for the new steering wheel.

    Today I went back at it. Got everything stripped down to the block in about three hours. It helped a lot having the flex joint in the header, I didn't have to remove it completely as I have had to do in the past with other pieces. I forgot what a PITA it is removing the head, having sore muscles certainly didn't help matters any. Here is how she sits now:



    The mail delivered my horn ring (you need one of these if you plan on using a horn button, otherwise the button will rattle around in the center hole). Once I get the engine back together I can get the steering wheel installed.

  11. The Following 4 Users Say Thank You to chiefmg For This Useful Post:

    Greasemonkey2000 (02-02-2018),JamieH (01-23-2018),kung fu jesus (01-23-2018),tsingson (01-23-2018)

  12. #743
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    finally got back to working on the head swap today. Went about swapping the exhaust cam over and installing the JDM intake cam. Moved the front coolant tap and the rear thermostat housing (this required clean-up and the use of sealant for the front O-ring and a new factory gasket on the rear). The Allen socket head cap screws I used for the thermostat housing showed signs of rust so I made a trip to Ace and bought some stainless replacements. Here is all that:







    Before I put the head in place I decided to remove the three exhaust manifold studs that I had to replace with longer studs for the supercharger manifold. Two came out with no problem but the last one was a PITA. Kroil was my friend in this. Once I had it out I could see the threads in the head looked stripped. I'll have to go to my local hardware store that carries metric taps and get one to chase the threads with. Couldn't get a picture of this one.

    Next I tackled the crap on the pistons. I am not quite sure what this was, possibly oil that appeared to be leaking by the valve seals. I used some BrakeKleen, let that soak in and then hit it with a nylon cleaning wheel on my drill. Here are before and after pictures of that:







    Finally, the other day I looked at the MS steering wheel hub to see how I could move things around so the Momo wheel would line up properly and allow the turn signal canceling piece to be in the right orientation. It appeared that I could remove the black plastic piece from the hub and reorient it . After some gentle work I was able to do so. Blurry picture of what I am talking about, I will try getting better shots once I get to work on installing the wheel (you are looking at the small black piece in the center):


  13. The Following 4 Users Say Thank You to chiefmg For This Useful Post:

    Agent☣Orange (02-17-2018),Demon I Am (01-29-2018),Greasemonkey2000 (02-02-2018),MiataQuest (01-29-2018)

  14. #744
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    Despite it still being chilly today, got back out in the garage and moved forward. I neglected to talk about using lubricant when installing the parts on the head. If the cams/lifters aren't lubed, the first start with result in a lot of wear at a minimum. In the past I have used a moly paste, while I was out the other day I looked to see what was available in an parts store and found some Lucas semi-synthetic lube that was a liquid. With the ARP head studs I have you also have to use lubricant, they have their own special formula. When you buy the stud kit they send you a little packet of the stuff, but I went through that and went ahead and bought a can of it. Here is what I am talking about:



    Started today off with cleaning things up. First thing done was chasing the threads in the hole for the exhaust manifold stud that fought me during removal with a tap from a set I picked up from Harbor Freight (this one takes a M10 X 1.25). I used BrakeKleen and sprayed down into the stud holes in the block to clean them out. You don't want to leave any liquid inside the holes, you can actually get hydraulic lock when installing the fasteners and they won't seat properly. I use a paper towel that I screw into a taper and insert that to absorb the fluid. Next I finished cleaning up the mating surface of the block using my sanding board. Cleaned all that residue off. Next up was cleaning all the assembly lube off the studs. Again I used BrakeKleen, wiping the studs down with a paper towel. In order to get any crud out of the threads I use a paper towel forced into the thread valley with my thumbnail and then turn the stud. Works great. Next step was to lube the threads and insert the studs into the block. You don't want to glob the lube on but you want to make sure there is an even coat on all the threads. Couldn't really get a good picture, the gray on the threads is what I'm talking about:



    Once the studs are in the block, you will see the forward-most one sticks up a little compared to the others. This is not an issue:



    Got all the studs installed, put the gasket in place double-checking that I had it aligned correctly, lubed the upper threads on the studs then put the head in place. Cleaned up the nuts and washers, then lubed them and put all on. At this point I want to touch on the importance of constantly researching. I came across something about the torque values that ARP gives for the head studs. General consensus is that they are too high. Originally their instructions said torque to 80 lb-ft, now they have dropped that to 65 lb-ft. Factory spec is 56-60 lb-ft. I decided to torque the new head to 56 lb-ft in three steps. Got that all done without issue.

    Whenever you do any work to your car, it's a good idea to take a look around where you are working, even at stuff you aren't touching. When I was disassembling things I found one of the heater hoses was being cut right where the end of the pipe it was attached to ended. Bought a replacement from Mazda and changed that out. You can see from the following pictures how it was being cut. Also, the new hose is slightly different in configuration from the old one (I have changed these hoses since buying the car, but I can't recall where I got them from).





    Put the exhaust manifold in place with a couple of nuts on it finger tight just to keep it from banging around. Finally, while looking things over to make sure I hadn't missed anything, I noticed a couple of big holes in the center of the head that I couldn't recall taking anything out of. Checked the old head and there are two Allen head plugs in those holes:





    I have no idea of the purpose of these, or why the shop that ported the head left them out. My big impact didn't budge either one, so I am plying the threads with Kroil to try and loosen them up.

  15. The Following 2 Users Say Thank You to chiefmg For This Useful Post:

    Agent☣Orange (02-17-2018),Greasemonkey2000 (02-02-2018)

  16. #745
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    Did a little research last night on Mazda Motorsports' site, those missing plugs are cheap. Went to the dealer this morning, cost was less than $4 each. Unfortunately there was only one in the GA location, the remaining stock is in TX and I have to wait a minimum of 5 days for delivery. Oh well, I'll get everything else buttoned up while I wait.

  17. #746
    4,000 rpm - entering the fun zone HarryB's Avatar
    Drives
    '04 Strato Blue NB2
    Location
    Greece
    Join Date
    Jun 2015
    Posts
    1,940
    Thanks Given
    3,733
    Thanked 1,301 Times in 765 Posts
    Regarding torquing down the head, as long as you do it in steps and in the correct order (and the studs/nuts can take it), I do not see any problem from the slightly higher than OEM 65lb-ft. Especially in a boosted engine, it may be a good thing.

  18. The Following 2 Users Say Thank You to HarryB For This Useful Post:

    chiefmg (02-01-2018),kung fu jesus (01-31-2018)

  19. #747
    Ninja Messiah kung fu jesus's Avatar
    Drives
    1999 White
    Location
    Roswell, GA
    Join Date
    Dec 2011
    Posts
    13,357
    Thanks Given
    1,878
    Thanked 5,172 Times in 2,475 Posts
    I do 65 ft/lb on ARP head studs. Never an issue. Harry has a good point pertaining to F/I applications.

  20. The Following User Says Thank You to kung fu jesus For This Useful Post:

    chiefmg (02-01-2018)

  21. #748
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    I know what you are both saying about higher clamping force on the head studs. I used to think the same way, but there is a good thread on Miataturbo.net that lays all this out. It is what I found when I was doing my research. There are a lot of posters who are running the factory torque specs with ARP studs and higher levels of boost than I am. I have to dig out the instructions I got with my studs but I seem to recall it said use 80 lb-ft. I'll see if I can get a picture of the old head, you can see where the washers underneath the nuts have pulled into the aluminum of the head. I can see if the clamping force is too high that the head would actually be seating unevenly on the block. It would take more time, money and effort than I have available to test this out so I'm just going to go with the empirical evidence.

  22. The Following User Says Thank You to chiefmg For This Useful Post:

    kung fu jesus (02-08-2018)

  23. #749
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    Weather is back to being wacky here, too cold to work in the garage. Horn surround for the steering wheel showed up today. I like how it looks. Here are shots of the wheel without and with the surround (that is the horn button I got from revlimiter):





    I have to measure to see the length of the button head screws I will need to use the surround.

  24. The Following User Says Thank You to chiefmg For This Useful Post:

    Greasemonkey2000 (02-02-2018)

  25. #750
    Nukuler banned! chiefmg's Avatar
    Location
    N KY
    Join Date
    Jan 2012
    Posts
    1,084
    Thanks Given
    122
    Thanked 726 Times in 333 Posts
    The plugs for the head finally showed up today. There is some sort of locking agent on the threads. At first I thought it was Loctite Blue, but a close look shows it has a granularity to it and seems to be thicker. Still too cold to work in the garage but at least I have these in hand.



    Also, while looking through eBay I found that there is in fact a part number for the foam piece that keeps the top latches quiet when the the top is open and they are shut. You may recall I made some myself but these will be much nicer. Put those on order from the dealer today. For anyone interested, the part number is NA01-R1-313B.

  26. The Following User Says Thank You to chiefmg For This Useful Post:

    tsingson (02-07-2018)

Page 50 of 53 FirstFirst ... 404344454647484950515253 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •